[已解决]宝塔国际版aapanel安装innoshop报错: 404及.env Permission denied
环境:centos7-64 aapanel php8.3
导入innsohop0.5完整包后,然后进入宝塔(aapanel)面板,将根目录手工指定到/www/wwwroot/wwwtttcom/public,同时取消open_basedir限制。这是由于innoshop使用的是laravel框架,public是应用程序目录,上一极是laravel框架目录。
环境:centos7-64 aapanel php8.3
导入innsohop0.5完整包后,然后进入宝塔(aapanel)面板,将根目录手工指定到/www/wwwroot/wwwtttcom/public,同时取消open_basedir限制。这是由于innoshop使用的是laravel框架,public是应用程序目录,上一极是laravel框架目录。
系统中部署了waf,默认是要接管80端口,可是lnmp环境又安装了宝塔国际版的aapanel,安装完后会生成一个默认的站点,当访问http://ip的时候会显示。
问题就产生了,如果waf先启动,后面lnmp启动就报错。如果lnmp先启动了,waf就不能成功启动。那怎样解决这个问题呢?
我们规划一下,让waf使用80端口,用户访问时流量选进waf洗一遍,然后再转发到后...
外面的vps使用国内的163和阿里云的代码仓库时,由于墙的存在,经常会卡死或ssh中断,这里改成国外的源。
官方 Vault 源(归档源,适合 EOL 系统)
地址:http://va...

使用lnmp.org环境在安装innoshop时,访问域名时显示空白,同时报http error 500的错误,去官方看了一下要求是php8.2以上版本,而我本机环境是7.x,需要安装php的多版本。
...vhost相关的配置文件在/usr/local,amce.sh php mysql nginx相关配置都在这个目录中。
lnmp.org脚本文件本身在/usr/bin/lnmp文件中。

最出名的当然是大名鼎鼎的putty,开源免费免安装,好是好,缺点也明显。使用ssh不光执行命令,有时候也要与本地电脑之间用sftp拖拖文件什么的。putt...
新建的vps,centos7 64位系统,在将/etc/ssh/sshd_confog的port修改为1234并重后连不上了。
使用web ssh连上,使用lsof -i:1234看到端口没有运行。使用netstat -ntpl | grep sshd也看到没有监听端口。
使用systemctl restart sshd报错,具体报错内容没有记,大约是无法启动之类的。...
为了避免网络上的不安全扫描,新开的linux vps要做第一件事,就是修改sshd端口。
如果对shell命令不熟,可以用putty把文件拖到本地电脑修改,会使用命令的直接在线修改即可。
vi /etc/ssh/sshd_config
找到#port 22这一行,将22修改为一个不常用端口。建议在10000-60000之间。
保存,...